On Wed, May 16, 2018 at 10:46:00PM +0300, Tomas Winkler wrote:
quoted
New wrappers are added tpm_cmd_ready() and tpm_go_idle() wrappers to
streamline tpm_try_transmit code. TPM_TRANSMIT_UNLOCKED flag is
abused
quoted
to resolve tpm spaces recursive calls to tpm_transmit().
This looks good and all but I don't think we want to abuse anything in the
driver code, do we?
It's not abuse just the flag UNLOCKED is not really named correctly
I think this has to be backported so wanted to do less invasive change.
In other words, either
1. New flag is to be added.
No
2. Rename the existing flag to something else than UNLOCKED (perhaps
SPACE).
Currently both TPM_TRANSMIT_UNLOCKED and TPM_TRANSMIT_RAW servers the same purpose, to resolve
the recursion in tpm tranmit.
What I believe should be done is to split the function into two to eliminate recursive call instead of using flags.
Please also there is clock_enable which is not protected from double call.
Thanks
Tomas
--
To unsubscribe from this list: send the line "unsubscribe linux-security-module" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html