[PATCH 1/6] genalloc: track beginning of allocations
From: Kees Cook <hidden>
Date: 2018-02-21 22:29:06
Also in:
linux-mm, lkml
On Tue, Feb 20, 2018 at 9:07 AM, Igor Stoppa [off-list ref] wrote:
On 13/02/18 01:52, Kees Cook wrote:quoted
On Mon, Feb 12, 2018 at 8:52 AM, Igor Stoppa [off-list ref] wrote:quoted
@@ -738,14 +1031,16 @@ EXPORT_SYMBOL(devm_gen_pool_create); #ifdef CONFIG_OF /** - * of_gen_pool_get - find a pool by phandle property + * of_gen_pool_get() - find a pool by phandle property * @np: device node * @propname: property name containing phandle(s) * @index: index into the phandle array * - * Returns the pool that contains the chunk starting at the physical - * address of the device tree node pointed at by the phandle property, - * or NULL if not found. + * Return: + * * pool address - it contains the chunk starting at the physical + * address of the device tree node pointed at by + * the phandle property + * * NULL - otherwise */ struct gen_pool *of_gen_pool_get(struct device_node *np, const char *propname, int index)I wonder if this might be more readable by splitting the kernel-doc changes from the bitmap changes? I.e. fix all the kernel-doc in one patch, and in the following, make the bitmap changes. Maybe it's such a small part that it doesn't matter, though?I had the same thought, but then I would have made most of the kerneldoc changes to something that would be altered by the following patch, because it would have made little sense to fix only those parts that would have survived. If it is really a problem to keep them together, I could put these changes in a following patch. Would that be ok?
Hmmm... I think keeping it as-is would be better than a trailing docs-only patch. Maybe Jon has an opinion? -Kees -- Kees Cook Pixel Security -- To unsubscribe from this list: send the line "unsubscribe linux-security-module" in the body of a message to majordomo at vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html