On Fri, Nov 10, 2017 at 11:26 AM, Alexey Dobriyan [off-list ref] wrote:
On 11/9/17, Djalal Harouni [off-list ref] wrote:
quoted
+struct proc_fs_info {
+ struct pid_namespace *pid_ns;
+};
quoted
+static inline struct proc_fs_info *proc_sb(struct super_block *sb)
+{
+ return sb->s_fs_info;
+}
Can you rename this to "struct proc_super_block *" then?
That "info" suffix all over filesystems doesn't add much info itself
just more typing.
Ditto for "fs_info" identifiers.
Ok, will do.
quoted
+extern inline struct proc_fs_info *proc_sb(struct super_block *sb)
{ return NULL;}
extern inline?
Oups, sorry will fix it and try to compile without proc.
Thank you!
--
tixxdz
--
To unsubscribe from this list: send the line "unsubscribe linux-security-module" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html