On Fri, 10 Sep 2021 11:41:26 +0300, Dmitry Bogdanov wrote:
Many fabric modules provide their own implementation of enable
attribute in tpg.
The change set removes the code duplication and automatically adds
"enable" attribute for fabric modules that has an implementation of
fabric_enable_tpg() ops.
This patchset is intended for scsi-queue.
[...]
Applied to 5.16/scsi-queue, thanks!
[1/7] target: core: add common tpg/enable attribute
https://git.kernel.org/mkp/scsi/c/80ed33c8ba93
[2/7] target: iscsi: replace enable attr to ops.enable
https://git.kernel.org/mkp/scsi/c/382731ec01b3
[3/7] target: qla2xx: replace enable attr to ops.enable
https://git.kernel.org/mkp/scsi/c/cb8717a720a9
[4/7] target: sbp: replace enable attr to ops.enable
https://git.kernel.org/mkp/scsi/c/fb00af92e5db
[5/7] target: srpt replace enable attr to ops.enable
https://git.kernel.org/mkp/scsi/c/9465b4871af0
[6/7] target: ibm_vscsi: replace enable attr to ops.enable
https://git.kernel.org/mkp/scsi/c/d7e2932bba1b
[7/7] target: usb: replace enable attr to ops.enable
https://git.kernel.org/mkp/scsi/c/5384ee089d1f
--
Martin K. Petersen Oracle Linux Engineering