Thread (15 messages) flat view 15 messages, 4 authors, 11d ago

Re: [PATCH 1/3] dt-bindings: rtc: Add Raspberry Pi 5 RTC binding

From: sashiko-bot@kernel.org
Date: 2026-09-09 14:23:55
Also in: linux-devicetree

Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider:
- [Medium] The binding introduces a custom, un-prefixed `trickle-charge-microvolt` property instead of using the standard `trickle-voltage-millivolt` property, and fails to reference the common RTC schema.
- [Low] The YAML filename does not match the primary compatible string it defines.
- [Low] Spelling errors in the commit message.
--

commit 425dd29b0a89a2c3ccab5825c325cf7042fb52e4
Author: Sander Speetjens [off-list ref]

dt-bindings: rtc: Add Raspberry Pi 5 RTC binding

This commit adds device tree bindings for the Raspberry Pi 5 RTC, which is
located in a custom DA9091 PMIC and accessed through the firmware mailbox
interface.
Add device tree bindings for the Raspberry Pi 5 RTC.
Located in a custom DA9091 PMIC and accesed trough the firmware mailbox.
[Severity: Low]
This isn't a bug, but there are spelling mistakes in the commit message.
"accesed trough" should be "accessed through".
quoted hunk ↗ jump to hunk
diff --git a/Documentation/devicetree/bindings/rtc/raspberrypi,rtc-rpi.yaml b/Documentation/devicetree/bindings/rtc/raspberrypi,rtc-rpi.yaml
new file mode 100644
index 0000000000000..93430048355a8
--- /dev/null
+++ b/Documentation/devicetree/bindings/rtc/raspberrypi,rtc-rpi.yaml
@@ -0,0 +1,48 @@
[ ... ]
+properties:
+  compatible:
+    const: raspberrypi,rpi-rtc
[Severity: Low]
Does this compatible string intentionally differ from the filename? The YAML
filename (raspberrypi,rtc-rpi.yaml) does not match the defined primary
compatible string (raspberrypi,rpi-rtc), which goes against standard binding
naming conventions.
+
+  firmware:
+    $ref: /schemas/types.yaml#/definitions/phandle
+    description:
+      Phandle to the Raspberry Pi firmware device.
+
+  trickle-charge-microvolt:
+    description:
+      RTC backup battery trickle-charge voltage. A value of 0 disables
+      trickle charging.
[Severity: Medium]
Should this property use the standard trickle-voltage-millivolt property
name instead? If a custom property is strictly required here, shouldn't it
have a vendor prefix?

[ ... ]
+required:
+  - compatible
+  - firmware
+
+additionalProperties: false
[Severity: Medium]
Should this binding reference the common RTC schema? Setting
additionalProperties: false without including an $ref to rtc.yaml# will
strictly reject generic RTC properties. Any device tree developer attempting
to use standard RTC properties (like wakeup-source) on this node will
encounter schema validation failures.

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260909141300.1368790-1-sander.speetjens@gmail.com?part=1
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help