2013/3/18 Viresh Kumar [off-list ref]:
On Mon, Mar 18, 2013 at 9:09 PM, Frederic Weisbecker [off-list ref] wrote:
quoted
2013/3/18 Viresh Kumar [off-list ref]:
quoted
quoted
+static inline int sched_select_cpu(unsigned int sd_flags)
+{
+ return raw_smp_processor_id();
I feel this should be symetric with the requirement of having
preemption disabled as in the CONFIG_NO_HZ version. This should be
smp_processor_id().
Yes, my fault.
quoted
quoted
+int sched_select_cpu(unsigned int sd_flags)
It would be nice to have some more precise naming. sched_select_busy_cpu() ?
You are correct that name can be improved but busy may give it a different
meaning. Maybe sched_select_non_idle_cpu()?
That works too yeah.
Thanks.