[PATCH for-next 0/7] RTRS renaming
flat view
STALE1745d
From: Jack Wang <jinpu.wang@ionos.com>
Date: 2021-12-23 10:42:33
Hi Jason, hi Leon,
This patchset from Vaishali, renames a few internal structures to make
the code easier to understand.
rtrs_sess is in fact a path. rtrs_clt/_srv is in fact a session.
This is a mess and makes it difficult to get into the code.
The patchset is based on rdma/for-next:
c8f476da84ad ("Merge branch 'mlx5-next' of git://git.kernel.org/pub/scm/linux/kernel/git/mellanox/linux")
Happy holidays!
Thanks!
Vaishali Thakkar (7):
RDMA/rtrs: Rename rtrs_sess to rtrs_path
RDMA/rtrs-srv: Rename rtrs_sess to rtrs_path
RDMA/rtrs-clt: Rename rtrs_sess to rtrs_path
RDMA/rtrs-srv: Rename rtrs_srv_sess to rtrs_srv_path
RDMA/rtrs-clt: Rename rtrs_clt_sess to rtrs_clt_path
RDMA/rtrs-srv: Rename rtrs_srv to rtrs_srv_sess
RDMA/rtrs-clt: Rename rtrs_clt to rtrs_clt_sess
drivers/block/rnbd/rnbd-clt.c | 4 +-
drivers/block/rnbd/rnbd-clt.h | 2 +-
drivers/block/rnbd/rnbd-srv.c | 8 +-
drivers/block/rnbd/rnbd-srv.h | 2 +-
drivers/infiniband/ulp/rtrs/rtrs-clt-stats.c | 8 +-
drivers/infiniband/ulp/rtrs/rtrs-clt-sysfs.c | 145 +--
drivers/infiniband/ulp/rtrs/rtrs-clt.c | 1083 +++++++++---------
drivers/infiniband/ulp/rtrs/rtrs-clt.h | 41 +-
drivers/infiniband/ulp/rtrs/rtrs-pri.h | 14 +-
drivers/infiniband/ulp/rtrs/rtrs-srv-sysfs.c | 121 +-
drivers/infiniband/ulp/rtrs/rtrs-srv.c | 664 +++++------
drivers/infiniband/ulp/rtrs/rtrs-srv.h | 16 +-
drivers/infiniband/ulp/rtrs/rtrs.c | 98 +-
drivers/infiniband/ulp/rtrs/rtrs.h | 34 +-
14 files changed, 1138 insertions(+), 1102 deletions(-)
--
2.25.1