Thread (8 messages) 8 messages, 4 authors, 2024-06-10

Re: [PATCH v2] md: make md_flush_request() more readable

From: Christoph Hellwig <hch@infradead.org>
Date: 2024-05-29 05:44:07
Also in: lkml

On Tue, May 28, 2024 at 09:49:44PM +0800, Li Nan wrote:

在 2024/5/28 21:23, Christoph Hellwig 写道:
quoted
Looks good:

Reviewed-by: Christoph Hellwig <hch@lst.de>

.
As suggested by Kuai, I will use bio_sectors instead of bi_size in v3.

-       if (bio->bi_iter.bi_size == 0) {
+       if (!bio_sectors(bio)) {
That looks weird.   bio_sectors literally just shifts
bio->bi_iter.bi_size to be in units of sectors, which doesn't
matter for comparing with 0.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help