Re: [PATCH] md: use MD_RESYNC_* whenever possible
From: Hou Tao <hidden>
Date: 2023-02-01 07:14:32
Hi, On 2/1/2023 3:06 PM, Song Liu wrote:
On Tue, Jan 31, 2023 at 10:18 PM Hou Tao [off-list ref] wrote:quoted
From: Hou Tao <redacted> Just replace magic numbers by MD_RESYNC_* enumerations. Signed-off-by: Hou Tao <redacted>Thanks for the patch. But it doesn't apply. I guess this is caused by some local debug commit?
Yes. Will send v2 based on md-next.
Songquoted
--- Hi, The cleanup patch should be sent out with patch "md: don't update recovery_cp when curr_resync is ACTIVE" together as a tiny patchset, but i forgot about it, so now send it alone. drivers/md/md.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)diff --git a/drivers/md/md.c b/drivers/md/md.c index 67ef1c768456..16da504aa156 100644 --- a/drivers/md/md.c +++ b/drivers/md/md.c@@ -6156,7 +6156,7 @@ static void md_clean(struct mddev *mddev) mddev->new_level = LEVEL_NONE; mddev->new_layout = 0; mddev->new_chunk_sectors = 0; - mddev->curr_resync = 0; + mddev->curr_resync = MD_RESYNC_NONE; atomic64_set(&mddev->resync_mismatches, 0); mddev->suspend_lo = mddev->suspend_hi = 0; mddev->sync_speed_min = mddev->sync_speed_max = 0;@@ -8887,7 +8887,7 @@ void md_do_sync(struct md_thread *thread) atomic_set(&mddev->recovery_active, 0); last_check = 0; - if (j>2) { + if (j >= MD_RESYNC_ACTIVE) { pr_debug("md: resuming %s of %s from checkpoint.\n", desc, mdname(mddev)); pr_info("md: resuming %s of %s from 0x%llx\n", desc, mdname(mddev), j);@@ -8967,7 +8967,7 @@ void md_do_sync(struct md_thread *thread) if (j > max_sectors) /* when skipping, extra large numbers can be returned. */ j = max_sectors; - if (j > 2) + if (j >= MD_RESYNC_ACTIVE) mddev->curr_resync = j; mddev->curr_mark_cnt = io_sectors; if (last_check == 0) --2.29.2