Re: [PATCH 04/23] devtmpfs: refactor devtmpfsd()

From
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date
2020-07-28 16:59:23
Also in
linux-api, linux-fsdevel, lkml
Reply to
Christoph Hellwig, 2020-07-28
On Tue, Jul 28, 2020 at 06:33:57PM +0200, Christoph Hellwig wrote:
Split the main worker loop into a separate function.  This allows
devtmpfsd_setup to be marked __init, which will allows us to call
__init routines for the setup work.  devtmpfѕ itself needs a __ref
marker for that to work, and a comment explaining why it works.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Thread (35 messages) 35 messages, 6 authors, last reply 2020-09-04
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help