Re: add file system helpers that take kernel pointers for the init code v3
From: Linus Torvalds <torvalds@linux-foundation.org>
Date: 2020-07-26 15:49:52
Also in:
linux-api, linux-fsdevel, lkml
From: Linus Torvalds <torvalds@linux-foundation.org>
Date: 2020-07-26 15:49:52
Also in:
linux-api, linux-fsdevel, lkml
On Sun, Jul 26, 2020 at 12:14 AM Christoph Hellwig [off-list ref] wrote:
Hi Al and Linus, currently a lot of the file system calls in the early in code (and the devtmpfs kthread) rely on the implicit set_fs(KERNEL_DS) during boot. This is one of the few last remaining places we need to deal with to kill off set_fs entirely, so this series adds new helpers that take kernel pointers. These helpers are in init/ and marked __init and thus will be discarded after bootup. A few also need to be duplicated in devtmpfs, though unfortunately.
I see nothing objectionable here.
The only bikeshed comment I have is that I think the "for_init.c" name
is ugly and pointless - I think you could just call it "fs/init.c" and
it's both simpler and more straightforward. It _is_ init code, it's
not "for" init.
Other than that it all looked straightforward to me.
Linus