Thread (3 messages) 3 messages, 3 authors, 2020-03-11

Re: [PATCH v3] block: refactor duplicated macros

From: Jens Axboe <axboe@kernel.dk>
Date: 2020-03-11 12:58:45
Also in: linux-bcache, linux-block, linux-mmc, linux-nfs, linux-scsi, lkml, nvdimm, xen-devel

On 3/10/20 6:22 PM, Matteo Croce wrote:
The macros PAGE_SECTORS, PAGE_SECTORS_SHIFT and SECTOR_MASK are defined
several times in different flavours across the whole tree.
Define them just once in a common header.

While at it, replace replace "PAGE_SHIFT - 9" with "PAGE_SECTORS_SHIFT" too
and rename SECTOR_MASK to PAGE_SECTORS_MASK.
Applied, thanks.

-- 
Jens Axboe
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help