On 11/18/18 7:23 PM, Ming Lei wrote:
On Fri, Nov 16, 2018 at 02:13:05PM +0100, Christoph Hellwig wrote:
quoted
quoted
-#define bvec_iter_page(bvec, iter) \
+#define mp_bvec_iter_page(bvec, iter) \
(__bvec_iter_bvec((bvec), (iter))->bv_page)
-#define bvec_iter_len(bvec, iter) \
+#define mp_bvec_iter_len(bvec, iter) \
I'd much prefer if we would stick to the segment naming that
we also use in the higher level helper.
So segment_iter_page, segment_iter_len, etc.
We discussed the naming problem before, one big problem is that the 'segment'
in bio_for_each_segment*() means one single page segment actually.
If we use segment_iter_page() here for multi-page segment, it may
confuse people.
Of course, I prefer to the naming of segment/page,
And Jens didn't agree to rename bio_for_each_segment*() before.
I didn't like frivolous renaming (and I still don't), but mp_
is horrible imho. Don't name these after the fact that they
are done in conjunction with supporting multipage bvecs. That
very fact will be irrelevant very soon
--
Jens Axboe