Thread (19 messages) 19 messages, 4 authors, 2016-09-30

Re: [dm-devel] [PATCH 03/10] md/dm-crypt: Rename a jump label in crypt_message()

From: SF Markus Elfring <hidden>
Date: 2016-09-29 15:44:20
Also in: dm-devel, kernel-janitors, lkml

In what bizzaro world is the "current Linux coding style convention"
Do you look at the evolution for a document like "CodingStyle"?

quoted
-
-error:
+show_warning:
 	DMWARN("unrecognised message received.");
 	return -EINVAL;
 }
"show_warning" is better than "error"
I got such an impression.

when the net result of the goto is that the function returns -EINVAL?!?
Do other identifiers fit better for the desired description of "what" and "why"
by jump labels?

Please give it up with these drive-by shooting of auto-generated patches.
This update step was not auto-generated.

There are further change possibilities where special analysis tools
can help in the corresponding software development.

You're just embarassing yourself.
Do you find any of my update suggestions worth for further considerations?

Regards,
Markus
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help