Thread (5 messages) 5 messages, 4 authors, 2016-05-09

Re: [PATCH] md: make the code more readable in the for-loop

From: Shaohua Li <shli@kernel.org>
Date: 2016-05-08 23:03:23
Also in: lkml

On Sun, May 08, 2016 at 08:56:55PM +0800, Tiezhu Yang wrote:
quoted hunk ↗ jump to hunk
This patch modifies raid1.c, raid10.c and raid5.c
to make the code more readable in the for-loop
and also fixes the scripts/checkpatch.pl error:
ERROR: trailing statements should be on next line.

Signed-off-by: Tiezhu Yang <redacted>
@@ -3573,7 +3573,8 @@ static void handle_stripe_dirtying(struct r5conf *conf,
 		pr_debug("force RCW rmw_level=%u, recovery_cp=%llu sh->sector=%llu\n",
 			 conf->rmw_level, (unsigned long long)recovery_cp,
 			 (unsigned long long)sh->sector);
-	} else for (i = disks; i--; ) {
+	} else
+	for (i = disks - 1; i >= 0; i--) {
 		/* would I have to read this buffer for read_modify_write */
 		struct r5dev *dev = &sh->dev[i];
 		if ((dev->towrite || i == sh->pd_idx || i == sh->qd_idx) &&
Applied. I move the for statement to be in a {} of else statement.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help