Re: strange problem with raid6 read errors on active non-degraded array
From: Pedro Teixeira <hidden>
Date: 2014-07-02 14:14:06
Hi Lars, the output of those commands: root@nas3:/# cat /sys/block/sdb/queue/physical_block_size 4096 root@nas3:/# cat /sys/block/md0/queue/physical_block_size 4096 root@nas3:/# The strange thing here is that dmesg is not poluted with sata errors like it is usual when a hard disk has bad sectors or some other hardware problem. the only thing in dmesg that hints to why reading the md volume fails are from dm itself. Cheers Pedro Citando Lars Täuber
Hi Pedro, maybe an issue with the logical/physical blocksize? What tell these commands: cat /sys/block/sdb/queue/physical_block_size cat /sys/block/md0/queue/physical_block_size Seagate says there are 4096 bytes/sector on this devices. Lars
________________________________________________________________________________ Mensagem enviada através do email grátis AEIOU http://www.aeiou.pt -- To unsubscribe from this list: send the line "unsubscribe linux-raid" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html