replaced disk in RAID1 imsi array - how to activate?
flat view
From: Miquel van Smoorenburg <hidden>
Date: 2012-08-09 13:42:06
Setup: kernel 3.2.21 (debian testing), mdadm 3.2.5.
I created a RAID1 imsi array on a supermicro server for testing
purposes. I'm trying to see what happens if I hot-remove disks,
hot-add them, reboot, etc to test the resiliency of this setup.
So I removed (by pulling it out) one disk, then simulated adding
a blank replacement disk by putting it back in and running
mdadm --zero-superblock on it.
I re-added it to the container with mdadm /dev/md127 --add /dev/sda..
and now it just sits there. How do I get the RAID1 array (dev/md126)
to start using this disk? The manpage says:
-a, --add
hot-add listed devices. If a device appears to have recently
been part of the array (possibly it failed or was removed) the
device is re-added as described in the next point. If that
fails or the device was never part of the array, the device is
added as a hot-spare. If the array is degraded, it will imme‐
diately start to rebuild data onto that spare.
However, nothing is happening:
root@server3-b05-tpb:~/tmp# cat /proc/mdstat
Personalities : [raid1]
md126 : active raid1 sdb[0]
31457280 blocks super external:/md127/0 [2/1] [_U]
md127 : inactive sda[1](S) sdb[0](S)
6306 blocks super external:imsm
Thanks,
Mike.
--
To unsubscribe from this list: send the line "unsubscribe linux-raid" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html