On Tue, 17 Apr 2012 16:49:50 +0800 "majianpeng" [off-list ref] wrote:
quoted hunk ↗ jump to hunk
quoted
From 2c637bca4e50e87f7b4e6b3abce27f8cd935fd92 Mon Sep 17 00:00:00 2001
From: majianpeng <redacted>
Date: Tue, 17 Apr 2012 16:47:07 +0800
Subject: [PATCH] md/raid10:using conf->chunk_mask instead "chunk_secotrs -
1".
Signed-off-by: majianpeng <redacted>
---
drivers/md/raid10.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/md/raid10.c b/drivers/md/raid10.c
index c8dbb84..5734d92 100644
--- a/drivers/md/raid10.c
+++ b/drivers/md/raid10.c
@@ -601,7 +601,7 @@ static int raid10_mergeable_bvec(struct request_queue *q,
unsigned int bio_sectors = bvm->bi_size >> 9;
if (conf->near_copies < conf->raid_disks) {
- max = (chunk_sectors - ((sector & (chunk_sectors - 1))
+ max = (chunk_sectors - ((sector & conf->chunk_mask)
+ bio_sectors)) << 9;
if (max < 0)
/* bio_add cannot handle a negative return */
Doesn't apply to latest code (in for-next).
And are you sure that it is actually an improvement? 'chunk_sectors' is
probably in a register, conf->chunk_mask is not.
I really am not interested in micro-optimisations like this (as I have said
before).
An please try to fix up your mailing process so that patch doesn't have
duplicate headers.
NeilBrown