Thread (2 messages) 2 messages, 2 authors, 2009-06-03

Re: [PATCH v2 01/11] async_tx: rename zero_sum to val

From: Dan Williams <hidden>
Date: 2009-06-03 18:12:48

2009/5/29 Sosnowski, Maciej [off-list ref]:
Dan Williams wrote:
quoted
'zero_sum' does not properly describe the operation of generating parity
and checking that it validates against an existing buffer.  Change the
name of the operation to 'val' (for 'validate').  This is in
anticipation of the p+q case where it is a requirement to identify the
target parity buffers separately from the source buffers, because the
target parity buffers will not have corresponding pq coefficients.

Signed-off-by: Dan Williams <redacted>
---
 arch/arm/mach-iop13xx/setup.c |    8 ++++----
 arch/arm/plat-iop/adma.c      |    2 +-
 crypto/async_tx/async_xor.c   |   16 ++++++++--------
 drivers/dma/dmaengine.c       |    4 ++--
 drivers/dma/iop-adma.c        |   38 +++++++++++++++++++-------------------
 drivers/md/raid5.c            |    2 +-
 include/linux/async_tx.h      |    2 +-
 include/linux/dmaengine.h     |    8 ++++----
 8 files changed, 40 insertions(+), 40 deletions(-)
Acked-by: Maciej Sosnowski <redacted>

with following comments:
quoted
@@ -1072,10 +1072,10 @@ iop_adma_xor_zero_sum_self_test(struct
iop_adma_device *device)
               dma_srcs[i] = dma_map_page(dma_chan->device->dev,
                                          zero_sum_srcs[i], 0, PAGE_SIZE,
                                          DMA_TO_DEVICE);
-       tx = iop_adma_prep_dma_zero_sum(dma_chan, dma_srcs,
-                                       IOP_ADMA_NUM_SRC_TEST + 1, PAGE_SIZE,
-                                       &zero_sum_result,
-                                       DMA_PREP_INTERRUPT | DMA_CTRL_ACK);
+       tx = iop_adma_prep_dma_xor_val(dma_chan, dma_srcs,
+                                      IOP_ADMA_NUM_SRC_TEST + 1, PAGE_SIZE,
+                                      &zero_sum_result,
+                                      DMA_PREP_INTERRUPT | DMA_CTRL_ACK);
What about zero_sum_srcs and zero_sum_result? Shouldn't they be renamed too?
No, the hardware specification calls the operation "zero sum", so it
is fine that the kernel calls it one thing but the driver translates
it into something else.

Thanks,
Dan
--
To unsubscribe from this list: send the line "unsubscribe linux-raid" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help