Thread (1 message) 1 message, 1 author, 2005-03-11

Re: Problems with Linux RAID in kernel 2.6

From: Neil Brown <hidden>
Date: 2005-03-11 05:29:10

On Thursday March 10, jrojomartinez@mi.madritel.es wrote:
Hi,

  I have many problems with RAID in kernel 2.6.10.
..
  And dmesg says:

md: raidstart(pid 2944) used deprecated START_ARRAY ioctl. This will not	<-- !!!
be supported beyond 2.6								<-- !!!
Take the hint.  Don't use 'raidstart'.  It seems to work, but it will
fail you when it really counts.  In fact, I think it is failing for
you now.

Use mdadm to assemble your arrays.
  And with mdadm also fails:

centralmad:~# mdadm -R /dev/md2 
mdadm: failed to run array /dev/md2: Invalid argument
You are using mdadm wrongly.  
You want something like:
  mdadm --assemble /dev/md2  /dev/sdb2 /dev/sdc2



centralmad:~# cat /proc/mdstat 
Personalities : [raid1] 
unused devices: <none>

  Moreover, dmesg says the md driver fails:

md: bug in file drivers/md/md.c, line 1514
This is (a rather non-helpful) way of saying that you tried to start
an array which contained no devices.

NeilBrown
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help