Thread (3 messages) 3 messages, 2 authors, 2005-02-14

Re: Linux 2.6.10 / RAID1 problem

From: Neil Brown <hidden>
Date: 2005-01-05 22:35:40

On Wednesday January 5, anders@anduras.de wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello!

I'm expirencing strange problems on my server running Software RAID1 (Mirroring) under
the Linux kernel 2.6.10. It works nicely under Linux 2.4.18!
Why do you think it is a raid problem rather than an ext3 problem?

....
Test case:
~ dd if=/dev/zero of=test0 bs=1M count=300
~ while :; do cp test0 test1; cp test1 test2; cp test2 test0; od test0; done

Error:
~ On Linux 2.4.18 it worked serveral hours perfectly (until I stopped it...)
~ On Linux 2.6.10 after some minutes the following (or similar) error occures:


EXT3-fs error (device md5): ext3_free_blocks_sb: bit already cleared for block 1303980
Aborting journal on device md5.
ext3_abort called.
.....

Does anybody have an idea?
What's the cause of this???
No (not me at least).
Are you able to run the same test on a single unraided drive?
Is there an known bug in the 2.6.10?
Is the Software RAID in the 2.6 series stable?
I am not aware of any significant problems with Software RAID in
2.6.10.
Any special kernel compile options not to use when using RAID?
No.
Any other (better) test to do?
As above, try without raid. 
If the problem goes away, come back here and report that fact.
If it doesn't report it to the ext3 mailing list, or to linux-kernel.

NeilBrown
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help