Thread (3 messages) 3 messages, 3 authors, 2002-11-21

Re: RFC - new raid superblock layout for md driver

flat view

From: John Stoffel <hidden>
Date: 2002-11-21 15:16:55
Also in: lkml

Steven> This is useful, atleast in the current raid implementation,
Steven> because md_import can be changed to return an error if the
Steven> device's unique identifier doesn't match the host identifier.
Steven> In this way, each device of a RAID volume is individually
Steven> locked to the specific host, and rejection occurs at import of
Steven> the device time.

This is a key issue on SANs as well.  I think that having the hosts'
UUID in the RAID superblock will allow rejection to happen
gracefully.  If needed, the user-land tools can have a --force
option. 

Steven> Perhaps locking using the name field would work except that
Steven> other userspace applications may reuse that name field for
Steven> some other purpose, not providing any kind of uniqueness.

I think the there needs to be two fields, a UUID field for the host
owning the RAID superblocks, and then a name field so that the host,
along with any other systems which can *view* the RAID superblock, can
know the user defined name.

John
   John Stoffel - Senior Unix Systems Administrator - Lucent Technologies
	 stoffel@lucent.com - http://www.lucent.com - 978-399-0479
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help