Thread (4 messages) 4 messages, 3 authors, 2021-10-20

Re: [RFC PATCH v4] workqueue: Introduce show_one_worker_pool and show_one_workqueue.

From: Tejun Heo <tj@kernel.org>
Date: 2021-10-20 16:19:58
Also in: lkml

On Wed, Oct 20, 2021 at 02:09:00PM +1100, Imran Khan wrote:
Currently show_workqueue_state shows the state of all workqueues and of
all worker pools. In certain cases we may need to dump state of only a
specific workqueue or worker pool. For example in destroy_workqueue we
only need to show state of the workqueue which is getting destroyed.

So rename show_workqueue_state to show_all_workqueues(to signify it
dumps state of all busy workqueues) and divide it into more granular
functions (show_one_workqueue and show_one_worker_pool), that would show
states of individual workqueues and worker pools and can be used in
cases such as the one mentioned above.

Also, as mentioned earlier, make destroy_workqueue dump data pertaining
to only the workqueue that is being destroyed and make user(s) of
earlier interface(show_workqueue_state), use new interface
(show_all_workqueues).

Signed-off-by: Imran Khan <redacted>
Applied to wq/for-5.16.

Thank you.

-- 
tejun
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help