Thread (2 messages) 2 messages, 2 authors, 2021-09-06

[PATCH] cpufreq: powernow: Prefer kcalloc over open coded arithmetic

STALE1854d

From: Len Baker <hidden>
Date: 2021-09-04 15:16:53
Also in: linux-hardening, lkml
Subsystem: cpu frequency scaling framework, the rest · Maintainers: "Rafael J. Wysocki", Viresh Kumar, Linus Torvalds

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the purpose specific kcalloc() function instead of the argument
size * count in the kzalloc() function.

[1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Len Baker <redacted>
---
 drivers/cpufreq/powernow-k7.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/cpufreq/powernow-k7.c b/drivers/cpufreq/powernow-k7.c
index 5d515fc34836..a9d2c7bae235 100644
--- a/drivers/cpufreq/powernow-k7.c
+++ b/drivers/cpufreq/powernow-k7.c
@@ -174,8 +174,8 @@ static int get_ranges(unsigned char *pst)
 	unsigned int speed;
 	u8 fid, vid;

-	powernow_table = kzalloc((sizeof(*powernow_table) *
-				(number_scales + 1)), GFP_KERNEL);
+	powernow_table = kcalloc(number_scales + 1, sizeof(*powernow_table),
+				 GFP_KERNEL);
 	if (!powernow_table)
 		return -ENOMEM;

--
2.25.1
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help