Thread (10 messages) 10 messages, 2 authors, 2018-08-21

Re: [PATCH v1 2/5] cpuidle: menu: Record tick delta value in struct menu_device

From: Rafael J. Wysocki <hidden>
Date: 2018-08-21 08:36:55
Also in: lkml

On Sunday, August 12, 2018 6:09:28 PM CEST Leo Yan wrote:
Since the tick delta is used in multiple places in menu_select(), it's
better to use single one variable to record this value; furthermore, for
more readable we can refactor the code to split a separate function to
making decision for stopping tick, which also needs to use tick delta
value as one metric for consideration.
I don't quite agree that allocating more per-CPU memory for readability
sake is a good idea, sorry.

Thanks,
Rafael
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help