Re: [PATCH v4 01/27] linkage: new macros for assembler symbols
From: Jiri Slaby <hidden>
Date: 2017-10-25 14:20:38
Also in:
lkml
From: Jiri Slaby <hidden>
Date: 2017-10-25 14:20:38
Also in:
lkml
On 10/06/2017, 05:23 PM, Josh Poimboeuf wrote:
On Mon, Oct 02, 2017 at 11:12:20AM +0200, Jiri Slaby wrote:quoted
SYM_CODE_INNER_LABEL -- only for labels in the middle of code SYM_CODE_INNER_LABEL_NOALIGN -- only for labels in the middle of codeWhy are the inner labels aligned by default? Seems like unaligned would be the most common case.
Correct: $ git grep -w SYM_CODE_INNER_LABEL_NOALIGN arch/|wc -l 20 $ git grep -w SYM_CODE_INNER_LABEL arch/|wc -l 3 Will switch them.
quoted
d) For data SYM_DATA_START -- global data symbol SYM_DATA_END -- the end of the SYM_DATA_START symbol SYM_DATA_END_LABEL -- the labeled end of SYM_DATA_START symbol SYM_DATA_SIMPLE -- start+end wrapper around simple global data SYM_DATA_SIMPLE_LOCAL -- start+end wrapper around simple local data"SIMPLE" seems superfluous, how about s/SYM_DATA_SIMPLE/SYM_DATA/ ?
Yup, makes sense, will do. thanks, -- js suse labs