Currently genpd queues a power off work for each of the subdomain's
corresponding masters, thus postponing the masters to be powered off to a later
point.
This series intends to improve that behaviour in genpd, by instead power off
the masters immediately, thus avoiding unnecessary works from being queued.
Ulf Hansson (3):
PM / Domains: Move genpd_power_off() above genpd_power_on()
PM / Domains: Rename is_async to one_dev_on for genpd_power_off()
PM / Domains: Power off masters immediately in the power off sequence
drivers/base/power/domain.c | 178 +++++++++++++++++++++++---------------------
1 file changed, 93 insertions(+), 85 deletions(-)
--
1.9.1