Thread (13 messages) 13 messages, 5 authors, 2015-12-10

Re: [PATCH v2 1/3] dt-binding: power: Add otg regulator binding

From: Sebastian Reichel <sre@kernel.org>
Date: 2015-12-09 22:20:54
Also in: linux-arm-msm, linux-devicetree, lkml

Hi,

On Wed, Dec 09, 2015 at 09:42:09AM -0800, Tim Bird wrote:
Or maybe our power maintainers will chime in with some wisdom. I
can't be the first person to be adding a charge pathway switch to
mainline, so I'm open to doing it the "right way". :-)
I don't think there is a standard way for this so far. Another
otg charger coming to my mindis bq2415x, which basically just
exposes the enable bit via sysfs.

Exposing the switch as regulator would be fine for me.
quoted
Thinking about this some more, the node name should be generic, so
just "regulator". The label does not need to be generic.
There are other switches in the charger block that are not
exposed yet.  This one handles the the OTG (vbus) charge pathway.
Others handle other charge pathways (some of which are used on phones
and some are not - they're used, e.g., on the dragonboard).  I'd
rather not give it a generic name, because eventually the driver
should expose those other switches as something as well.
otg_regulator: regulator@0 { }
other_regulator: regulator@1 { }

-- Sebastian

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help