Thread (1 message) 1 message, 1 author, 2011-06-23

Re: [Update][PATCH 7/8] PM / Domains: System-wide transitions support for generic domains (v3)

From: Alan Stern <stern@rowland.harvard.edu>
Date: 2011-06-23 18:22:18

On Thu, 23 Jun 2011, Rafael J. Wysocki wrote:
quoted
It should say "system suspend" rather than "system sleep".
It says "system sleep" to distinguish between the state of the system
("system sleep") and the operation leading to that state ("system suspend").
That terminology is used all over the document, so I don't think it's a good
idea to change it just for this specific paragraph.

I agree that "suspend" should be used where it talks about starting, stopping
etc.
quoted
Then to drive the point home, the following sentence chould say 
something like this:

If that is the case and none of the situations listed above takes place
(in particular, if the system is waking up from suspend and not from
hibernation), it may be more efficient to leave the devices that had
been suspended before the system suspend began in the suspended state.
That's fine by me, except that I'd simply say "(in particular, if the system
is not waking up from hibernation)".
Okay.

Alan Stern
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help