Re: [PATCH] PM: Hide CONFIG_PM from users
From: Rafael J. Wysocki <hidden>
Date: 2011-02-07 19:46:48
On Monday, February 07, 2011, Mark Brown wrote:
On Mon, Feb 07, 2011 at 08:14:03PM +0100, Rafael J. Wysocki wrote:quoted
On Monday, February 07, 2011, Mark Brown wrote:quoted
quoted
config PM_DEBUG bool "Power Management Debug Support"quoted
I think it would be better to simply rename CONFIG_PM_OPS into CONFIG_PM.That still leaves the IA64 emulator to worry about
Why exactly?
but I'm not fundamentally opposed to that, it achieves a similar effect. The main thing I'm looking for here is to cut down on the configuration options we have to maintain.
But I must say you chose a particularly bad time for that from my point of view.
quoted
However, there's a number of things that I'm afraid wouldn't build correctly if none of CONFIG_PM_SLEEP and CONFIG_PM_RUNTIME were set in that case.Actually CONFIG_PM_OPS probably also wants to be on independantly of those two sometimes for .poweroff() which I'd expect to run even if we can't suspend.
If you worry about that, then add CONFIG_PM_POWEROFF and make CONFIG_PM(_OPS) depend on it, but I don't think it really is worth it, because people generally don't make the poweroff code depend on CONFIG_PM. Thanks, Rafael