On Tue, Aug 04, 2009 at 11:36:12AM +0200, Albin Tonnerre wrote:
In a number of cases, the .suspend, .freeze, .poweroff and .resume,
.thaw, .restore functions are identical. However, they all need to be
assigned to avoid regressionsm as the previous code called .suspend
resp. .resume in all those cases. SIMPLE_PM_OPS allows to deal with
this case.
I'd much rather have conversions done with a bit more analysis now that
our framework is more flexible and we can have specialized routines for
hibernation and suspend.
Maybe we should try changing from run-time to build time warning so that
users are not overly concerned with it?
Thanks.
--
Dmitry