quoted
quoted
panic_blink = i8042_panic_blink;
return 0;
+ err_dev_async_unregister:
+ dev_async_unregister(&i8042_platform_device->dev);
err_free_device:
platform_device_put(i8042_platform_device);
err_unregister_driver:
I still do not like the interface: manually unregistering seems to be
ugly & error prone.
hmm, yes, we can check device->dev_async and unregister it in driver
core, at device_unregister time.
then I think we should rename the interfaces to:
device_enable_async_action(dev, type),
and device_disable_async_action(dev)
so that they are more like driver core helper functions.
what do you think?
Yes, that would be nicer.
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html