Re: [PATCH 0/11] PCI PM: Handling of PCI devices wake-up functionality
From: Jesse Barnes <hidden>
Date: 2008-06-25 22:05:08
Also in:
linux-acpi
From: Jesse Barnes <hidden>
Date: 2008-06-25 22:05:08
Also in:
linux-acpi
On Monday, June 23, 2008 10:34 am Rafael J. Wysocki wrote:
Hi, The purpose of the following series of patches is to rework the power management of PCI devices so that the handling of their wake-up functionality is consistent with the other PM operations and so that the user space can manage the wake-up functionality of PCI devices using the /sys/devices/.../power/wakeup interface regardless of whether the wake-up function is based on the native PCI mechanism (PME#), or it is handled by the platform (eg. ACPI). Apart from the ACPI and PCI changes necessary for this purpose, the series includes some clean-ups that are not strictly required, but make the code more straightforward and (IMHO) easier to follow. Please review.
This patchset looks really nice, and makes pci_enable_wake and such much more readable, IMO. How much testing has it seen? Do you think it's appropriate for 2.6.27? Thanks, Jesse