On Fri, Feb 7, 2025 at 12:48 AM David Lechner [off-list ref] wrote:
Reduce verbosity by using gpiod_multi_set_value_cansleep() instead of
gpiod_set_array_value_cansleep().
It seems you missed my comment.
+static void gpiod_set_array_single_value_cansleep(struct gpio_descs *descs,
int value)
This is not good namespacing. Can we change this while at it?
max3191x_...
(I would go with max3191x_set_modesel_pins() to make it shorter. I
have no clue why the function repeats so much from gpiod API naming.
Is there anything else which is named in a similar way? Perhaps fix it
by a separate patch?)
--
With Best Regards,
Andy Shevchenko
--
linux-phy mailing list
linux-phy@lists.infradead.org
https://lists.infradead.org/mailman/listinfo/linux-phy