Thread (37 messages) 37 messages, 10 authors, 2025-02-04

Re: [PATCH 00/13] gpiolib: add gpiods_set_array_value_cansleep

From: David Lechner <dlechner@baylibre.com>
Date: 2025-01-31 20:51:55
Also in: linux-gpio, linux-iio, linux-mmc, linux-sound, lkml, netdev

On 1/31/25 2:38 PM, Andrew Lunn wrote:
quoted
So I'm proposing that we add a gpiods_set_array_value_cansleep()
function that is a wrapper around gpiod_set_array_value_cansleep()
that has struct gpio_descs as the first parameter to make it a bit
easier to read the code and avoid the hard-coding temptation.
 
This looks reasonable.

How do you plan to get it merged, since you cross a lot of subsystems
here.

	Andrew
Since these are mostly small changes and most of the touched drivers aren't
seeing much action, I think it would be OK for as much as possible to go through
the GPIO tree.

We might need an immutable branch from that though since I know that iio: adc:
ad7606 is currently being actively worked on.

If there are any patches leftover that don't get acked to go through the GPIO
tree, I can resubmit them after the next kernel release cycle since none of
this is urgent anyway.


-- 
linux-phy mailing list
linux-phy@lists.infradead.org
https://lists.infradead.org/mailman/listinfo/linux-phy
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help