Hi Arnaldo,
On 9/3/2021 7:38 PM, Arnaldo Carvalho de Melo wrote:
Committer notes:
Rename 'struct perf_pmu_alias_name' to 'pmu_alias', the 'perf_' prefix
should be used for libperf, things inside just tools/perf/ are being
moved away from that prefix.
Also 'pmu_alias' is shorter and reflects the abstraction.
Also don't use 'pmu' as the name for variables for that type, we should
use that for the 'struct perf_pmu' variables, avoiding confusion. Use
'pmu_alias' for 'struct pmu_alias' variables.
I fully agree your recommended changes. I think Kan will agree too. :) Thanks so much!
Thanks
Jin Yao