Re: [PATCH] tools lib api fs: Move cgroupsfs_find_mountpoint()
flat view
From: Jiri Olsa <hidden>
Date: 2020-01-27 16:22:33
Also in:
lkml
On Mon, Jan 27, 2020 at 11:58:27PM +0900, Namhyung Kim wrote:
Hi Jiri, On Mon, Jan 27, 2020 at 8:12 PM Jiri Olsa [off-list ref] wrote:quoted
On Mon, Jan 27, 2020 at 07:00:31PM +0900, Namhyung Kim wrote: SNIPquoted
- - if (strlen(path) < maxlen) { - strcpy(buf, path); - return 0; - } - return -1; -} - static int open_cgroup(const char *name) { char path[PATH_MAX + 1];@@ -79,7 +20,7 @@ static int open_cgroup(const char *name) int fd; - if (cgroupfs_find_mountpoint(mnt, PATH_MAX + 1)) + if (cgroupfs_find_mountpoint(mnt, PATH_MAX + 1, "perf_event"))nice, but could you please follow fs API names and change the name to cgroupfs__mountpoint I think we don't need to define the rest of the functions now, if they are not used #define FS(name) \ const char *name##__mountpoint(void); \ const char *name##__mount(void); \ bool name##__configured(void); \ just follow the function nameI thought about it too, but still it has different arguments. So I left it as is... Do you really want to rename?
yea I think we should keep the same name, Arnaldo? jirka
Thanks Namhyung