Re: [PATCH v3 01/18] iommu: Add device dma ownership set/release interfaces
From: Joerg Roedel <joro@8bytes.org>
Date: 2021-12-06 13:36:03
Also in:
kvm, linux-iommu, lkml
On Mon, Dec 06, 2021 at 09:58:46AM +0800, Lu Baolu wrote:
quoted
From the perspective of who is initiating the device to do DMA, deviceDMA could be divided into the following types: DMA_OWNER_DMA_API: Device DMAs are initiated by a kernel driver through the kernel DMA API. DMA_OWNER_PRIVATE_DOMAIN: Device DMAs are initiated by a kernel driver with its own PRIVATE domain. DMA_OWNER_PRIVATE_DOMAIN_USER: Device DMAs are initiated by userspace.
I have looked at the other iommu patches in this series, but I still don't quite get what the difference in the code flow is between DMA_OWNER_PRIVATE_DOMAIN and DMA_OWNER_PRIVATE_DOMAIN_USER. What are the differences in the iommu core behavior based on this setting?
int iommu_device_set_dma_owner(struct device *dev,
enum iommu_dma_owner type, void *owner_cookie);
void iommu_device_release_dma_owner(struct device *dev,
enum iommu_dma_owner type);It the owner is a group-wide setting, it should be called with the group instead of the device. I have seen the group-specific funcitons are added later, but that leaves the question why the device-specific ones are needed at all.
+ enum iommu_dma_owner dma_owner; + refcount_t owner_cnt; + void *owner_cookie; };
I am also not quite happy yet with calling this dma_owner, but can't come up with a better name yet.
quoted hunk ↗ jump to hunk
struct group_device {@@ -621,6 +624,7 @@ struct iommu_group *iommu_group_alloc(void) INIT_LIST_HEAD(&group->devices); INIT_LIST_HEAD(&group->entry); BLOCKING_INIT_NOTIFIER_HEAD(&group->notifier); + group->dma_owner = DMA_OWNER_NONE;
DMA_OWNER_NONE is also questionable. All devices are always in one domain, and the default domain is always the one used for DMA-API, so why isn't the initial value DMA_OWNER_DMA_API? Regards, Joerg