jean.pihet@newoldbits.com writes:
From: Jean Pihet <redacted>
Extend the PM QoS kernel API:
- add a new PM QoS class PM_QOS_DEV_LATENCY for device wake-up latency
constraints
- make the pm_qos_add_request API more generic by using a parameter of
type struct pm_qos_parameters
- minor clean-ups and rename of struct fields:
. rename pm_qos_class to class and pm_qos_req to req in internal code
. consistenly use req and params as the API parameters
. rename struct pm_qos_request_list to struct pm_qos_request
- update the in-kernel API callers to the new API
Signed-off-by: Jean Pihet <redacted>
---
arch/arm/plat-omap/i2c.c | 20 -----
drivers/i2c/busses/i2c-omap.c | 35 ++++++---
More on breaking this patch up...
Since the OMAP I2C driver is not a current PM QoS API user, it doesn't
really belong in this patch which is converting existing PM QoS API
users. The OMAP I2C conversion should be its own patch.
Kevin