Thread (6 messages) 6 messages, 5 authors, 2021-10-29

Re: [PATCH] nvmet: prefer flex_array_size and struct_size over open coded arithmetic

From: Chaitanya Kulkarni <hidden>
Date: 2021-10-27 00:14:05
Also in: linux-hardening, lkml

On 10/24/21 10:29 AM, Len Baker wrote:
External email: Use caution opening links or attachments


In an effort to avoid open-coded arithmetic in the kernel [1], use the
flex_array_size() and struct_size() helpers instead of an open-coded
calculation.

[1] https://github.com/KSPP/linux/issues/160

Signed-off-by: Len Baker <redacted>
---
Looks good.

Reviewed-by: Chaitanya Kulkarni <kch@nvidia.com>

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help