The wrapper is to:
- follow the naming convention for mpath functions called from core
- allow the implementation to have more logic in future
As for error propagation, nvme_start_ctrl is void.
Any error in nvme_read_ana_log() will have the same effect as
when it is invoked from nvme_ana_work(), i.e. will be ignored.
On Mon, Sep 20, 2021 at 08:35:34AM +0200, Christoph Hellwig wrote:
On Sat, Sep 18, 2021 at 03:57:29PM -0600, Anton Eidelman wrote:
quoted
+void nvme_mpath_update(struct nvme_ctrl *ctrl)
+{
+ nvme_read_ana_log(ctrl);
+}
What is the point of this wrapper vs just calling nvme_read_ana_log
directly? Also shouldn;t we propagate the error here and through
nvme_start_ctrl?
_______________________________________________
Linux-nvme mailing list
Linux-nvme@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-nvme