Thread (11 messages) 11 messages, 6 authors, 2021-06-09

Re: [PATCH v6 1/2] ACPI: Move check for _DSD StorageD3Enable property to acpi

From: Keith Busch <kbusch@kernel.org>
Date: 2021-06-08 20:01:17
Also in: linux-acpi

On Tue, Jun 08, 2021 at 07:35:46AM +0200, Christoph Hellwig wrote:
On Mon, Jun 07, 2021 at 12:31:55PM -0500, Mario Limonciello wrote:
quoted
+/**
+ * acpi_storage_d3 - Check if a storage device should use D3.
+ * @dev: Device to check
+ *
+ * Returns %true if @dev should be put into D3 when the ->suspend method is
+ * called, else %false.  The name of this function is somewhat misleading
+ * as it has nothing to do with storage except for the name of the ACPI
+ * property.  On some platforms resume will not work if this hint is ignored.
+ *
+ */
I still do not like this comment.  There is nothing about only using this
for storage devices.  It is specific to a PCIe slot, and if I plug
something that is not a storage device into it the same restrictions
still apply.
Hm, I thought this comment was good. Despite the dupious connection to
storage, the function name matches the ACPI property, so an explanation
for this misnomer seems appropriate.

_______________________________________________
Linux-nvme mailing list
Linux-nvme@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-nvme
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help