Re: [RFC PATCH v3 1/3] io_uring: add helper for uring_cmd completion in submitter-task
From: Christoph Hellwig <hch@lst.de>
Date: 2021-03-18 05:48:35
Also in:
io-uring
From: Christoph Hellwig <hch@lst.de>
Date: 2021-03-18 05:48:35
Also in:
io-uring
On Thu, Mar 18, 2021 at 10:55:55AM +0530, Kanchan Joshi wrote:
I started with that, but the problem was implementing the driver callback .
The callbacks receive only one argument which is "struct callback_head
*", and the driver needs to extract "io_uring_cmd *" out of it.
This part -
+static void uring_cmd_work(struct callback_head *cb)
+{
+ struct io_kiocb *req = container_of(cb, struct io_kiocb, task_work);
+ struct io_uring_cmd *cmd = &req->uring_cmd;
If the callback has to move to the driver (nvme), the driver needs
visibility to "struct io_kiocb" which is uring-local.
Do you see a better way to handle this?
Can't you just add a helper in io_uring.c that does something like this:
struct io_uring_cmd *callback_to_io_uring_cmd(struct callback_head *cb)
{
return &container_of(cb, struct io_kiocb, task_work)->uring_cmd;
}
EXPORT_SYMBOL_GPL(callback_to_io_uring_cmd);
_______________________________________________
Linux-nvme mailing list
Linux-nvme@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-nvme