[PATCH 4/4] nvme: split pci module out of core module
From: mlin@kernel.org (Ming Lin)
Date: 2016-02-10 15:31:05
From: mlin@kernel.org (Ming Lin)
Date: 2016-02-10 15:31:05
On Wed, Feb 10, 2016@7:12 AM, Keith Busch [off-list ref] wrote:
On Mon, Feb 08, 2016@02:24:44PM -0800, Ming Lin wrote:quoted
This splits nvme.ko into 2 modules: nvme-core.ko: the core part nvme.ko: the PCI driverDo we want to let PCI take the generic "nvme.ko" name? What will the other nvme transport modules be called?
Better name would be: nvme_pci.ko, but that may break, for example, userspace scripts. nvme_rdma.ko: IB/RoCE/iWARP nvme_fc.ko: Fibre Channel nvme_vhost.ko ....
Otherwise, looks good to me.