Thread (8 messages) flat view 8 messages, 3 authors, 15h ago

Re: [PATCH v4 1/3] module/kallsyms: Rename is_mapping_symbol() to is_ignored_kernel_symbol()

From: Tiezhu Yang <yangtiezhu@loongson.cn>
Date: 2026-08-25 01:39:41
Also in: loongarch

On 2026/8/24 下午4:45, Huacai Chen wrote:
Hi, Tiezhu,

On Thu, Aug 20, 2026 at 8:50 PM Tiezhu Yang [off-list ref] wrote:
quoted
The helper function is_mapping_symbol() historically checks for both
local labels prefixed with ".L" or "L0" and mapping symbols prefixed
with "$".

Rename it to is_ignored_kernel_symbol() to better reflect this actual
behavior and scope, preventing conceptual confusion.
I think is_ignored_symbol() is enough, no "kernel" needed.
Hi Huacai,

Using is_ignored_kernel_symbol() was suggested by Petr [1] to maintain
consistency with the existing naming convention in tools/perf.

For me, either is_ignored_kernel_symbol() or is_ignored_symbol() is
fine. I will leave it to Petr to make the final call on this.

[1] 
https://lore.kernel.org/loongarch/96b0e23b-165d-4026-bdfe-f8cd8ceb36ba@suse.com/ (local)

Thanks,
Tiezhu
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help