Reviews by heiko@sntech.de
· linux-mmc
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-mmc archive.
100 attestations · capped at 100 most-recent. (19 Acked-by, 47 Reviewed-by, 7 Suggested-by, 27 Tested-by)
-
STALE124d
REVIEWED: 3 (3M) Re: [PATCH] dt-bindings: mmc: rockchip-dw-mshc: Fix the RV1103B compatible
2026-03-13 · Reviewed-by -
STALE153d
REVIEWED: 3 (3M) Re: [PATCH v2] dt-bindings: mmc: rockchip-dw-mshc: Add RV1103B compatible
2026-02-07 · Reviewed-by -
STALE186d
REVIEWED: 3 (3M) Re: [PATCH v4 3/5] mmc: dw_mmc-rockchip: Fix runtime PM support for internal phase support
2026-01-16 · Reviewed-by -
STALE256d
REVIEWED: 3 (3M) Re: [PATCH] mmc: dw_mmc-rockchip: Fix wrong internal phase calculate
2025-11-06 · Acked-by -
STALE310d
REVIEWED: 8 (8M) [PATCH v4 1/4] pmdomain: rockchip: enable ROCKCHIP_PM_DOMAINS with ARCH_ROCKCHIP
2025-09-15 · Acked-by -
STALE310d
REVIEWED: 8 (8M) [PATCH v4 1/4] pmdomain: rockchip: enable ROCKCHIP_PM_DOMAINS with ARCH_ROCKCHIP
2025-09-15 · Suggested-by -
STALE316d
REVIEWED: 3 (3M) Re: [PATCH v3 1/4] pmdomain: rockchip: enable ROCKCHIP_PM_DOMAINS with ARCH_ROCKCHIP
2025-09-12 · Acked-by -
STALE316d
[PATCH v3 1/4] pmdomain: rockchip: enable ROCKCHIP_PM_DOMAINS with ARCH_ROCKCHIP
2025-09-12 · Suggested-by -
STALE310d
[PATCH v2 2/2] ARM: rockchip: select ROCKCHIP_PM_DOMAINS
2025-09-12 · Suggested-by -
STALE310d
[PATCH v2 1/2] arm64: select ROCKCHIP_PM_DOMAINS with ARCH_ROCKCHIP
2025-09-12 · Suggested-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 19/20] clk: sp7021: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 20/20] phy: rockchip-pcie: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 18/20] PM / devfreq: rockchip-dfi: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 17/20] PCI: dw-rockchip: Switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 16/20] PCI: rockchip: Switch to FIELD_PREP_WM16* macros
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 15/20] net: stmmac: dwmac-rk: switch to FIELD_PREP_WM16 macro
2025-08-27 · Acked-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 14/20] ASoC: rockchip: i2s-tdm: switch to FIELD_PREP_WM16_CONST macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 13/20] drm/rockchip: dw_hdmi: switch to FIELD_PREP_WM16* macros
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 12/20] phy: rockchip-usb: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 11/20] drm/rockchip: inno-hdmi: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 10/20] drm/rockchip: dw_hdmi_qp: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 09/20] phy: rockchip-samsung-dcphy: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 08/20] drm/rockchip: vop2: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 07/20] drm/rockchip: dsi: switch to FIELD_PREP_WM16* macros
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 06/20] phy: rockchip-emmc: switch to FIELD_PREP_WM16 macro
2025-08-27 · Acked-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 05/20] drm/rockchip: lvds: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 04/20] media: synopsys: hdmirx: replace macros with bitfield variants
2025-08-27 · Acked-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 03/20] soc: rockchip: grf: switch to FIELD_PREP_WM16_CONST macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 02/20] mmc: dw_mmc-rockchip: switch to FIELD_PREP_WM16 macro
2025-08-27 · Reviewed-by -
STALE298d
REVIEWED: 3 (3M) Re: [PATCH v3 01/20] bitmap: introduce hardware-specific bitfield operations
2025-08-27 · Acked-by -
DORMANTno replies
REVIEWED: 3 (3M) Re: [PATCH v5 3/3] mmc: dw_mmc-rockchip: Add support for rk3576 SoCs
2024-08-29 · Reviewed-by -
DORMANTno replies
REVIEWED: 3 (3M) Re: [PATCH v5 2/3] mmc: dw_mmc-rockchip: Add internal phase support
2024-08-29 · Reviewed-by -
DORMANTno replies
REVIEWED: 3 (3M) Re: [PATCH v5 1/3] dt-bindings: mmc: Add support for rk3576 dw-mshc
2024-08-29 · Reviewed-by -
DORMANTno replies
REVIEWED: 4 (3M) [PATCH v3 05/11] dt-bindings: serial: snps-dw-apb-uart: Add Rockchip RK3576
2024-08-28 · Acked-by -
STALE695d
LANDED: 4 (3M) [PATCH v3 04/11] dt-bindings: mfd: syscon: Add rk3576 QoS register compatible
2024-08-28 · Acked-by -
DORMANTno replies
REVIEWED: 4 (3M) [PATCH v3 03/11] dt-bindings: i2c: i2c-rk3x: Add rk3576 compatible
2024-08-28 · Acked-by -
STALE696d
REVIEWED: 4 (3M) [PATCH v2 06/12] dt-bindings: serial: snps-dw-apb-uart: Add Rockchip RK3576
2024-08-23 · Acked-by -
STALE696d
REVIEWED: 4 (3M) [PATCH v2 05/12] dt-bindings: mfd: syscon: Add rk3576 QoS register compatible
2024-08-23 · Acked-by -
STALE696d
REVIEWED: 4 (3M) [PATCH v2 04/12] dt-bindings: iio: adc: Add rockchip,rk3576-saradc string
2024-08-23 · Acked-by -
STALE696d
REVIEWED: 4 (3M) [PATCH v2 03/12] dt-bindings: i2c: i2c-rk3x: Add rk3576 compatible
2024-08-23 · Acked-by -
STALE774d
REVIEWED: 3 (3M) Re: [PATCH v1 1/1] treewide: Align match_string() with sysfs_match_string()
2024-06-04 · Acked-by -
STALE1063d
REVIEWED: 3 (3M) Re: [PATCH v3 41/62] mmc: dw_mmc: rockchip: Convert to platform remove callback returning void
2023-07-28 · Acked-by -
STALE1236d
REVIEWED: 3 (3M) Re: [PATCH 1/2] dt-bindings: mmc: rockchip-dw-mshc: Add RK3588 compatible string
2023-02-13 · Reviewed-by -
STALE1279d
REVIEWED: 3 (3M) Re: [PATCH 2/2] dt-bindings: mmc: correct pwrseq node names
2023-01-24 · Reviewed-by -
STALE1279d
REVIEWED: 3 (3M) Re: [PATCH 1/2] dt-bindings: mmc: drop unneeded quotes
2023-01-20 · Reviewed-by -
STALE1395d
REVIEWED: 3 (3M) Re: [PATCH v1 03/11] dt-bindings: pwm: rockchip: add rockchip,rk3128-pwm
2022-09-23 · Acked-by -
STALE1472d
REVIEWED: 3 (3M) Re: [PATCH v3 4/4] riscv: dts: sifive: "fix" pmic watchdog node name
2022-06-13 · Reviewed-by -
STALE1517d
REVIEWED: 3 (3M) [PATCHv2 12/21] pinctrl/rockchip: add error handling for pull/drive register getters
2022-05-04 · Reviewed-by -
STALE1544d
REVIEWED: 3 (3M) Re: [PATCHv1 12/19] pinctrl/rockchip: add error handling for pull/drive register getters
2022-04-22 · Reviewed-by -
STALE3065d
REVIEWED: 3 (3M) Re: [PATCH] dt-bindings: rockchip-dw-mshc: use consistent clock names
2018-03-01 · Reviewed-by -
STALE3055d
REVIEWED: 3 (3M) [PATCH] mmc: dw_mmc-rockchip: correct property names in debug
2018-03-01 · Reviewed-by -
STALE2990d
REVIEWED: 3 (3M) Re: [PATCH 000/102] Convert drivers to explicit reset API
2017-07-20 · Acked-by -
DORMANTno replies
REVIEWED: 3 (3M) Re: [PATCH 000/102] Convert drivers to explicit reset API
2017-07-20 · Acked-by -
STALE3295d
REVIEWED: 3 (3M) [RESEND PATCH v2 3/7] Documentation: rockchip-dw-mshc: add description for rk3228
2017-06-22 · Reviewed-by -
STALE3321d
REVIEWED: 3 (3M) [PATCH v2 3/7] Documentation: rockchip-dw-mshc: add description for rk3228
2017-06-22 · Reviewed-by -
STALE3322d
REVIEWED: 3 (3M) Re: [PATCH 2/6] Documentation: rockchip-dw-mshc: add description for rk3228
2017-06-15 · Reviewed-by -
STALE3293d
REVIEWED: 3 (3M) Re: mmc: core: Fix access to HS400-ES devices
2017-03-10 · Tested-by -
STALE3420d
REVIEWED: 3 (3M) Re: [PATCH 1/7] dt-bindings: rockchip-dw-mshc: rename RK1108 to RV1108
2017-02-23 · Reviewed-by -
STALE3537d
REVIEWED: 5 (5M) [PATCHv3 7/9] mmc: dw_mmc: remove the unnecessary mmc_data structure
2016-11-17 · Tested-by -
STALE3537d
REVIEWED: 3 (3M) [PATCHv3 6/9] mmc: dw_mmc: use the cookie's enum values for post/pre_req()
2016-11-17 · Tested-by -
STALE3537d
REVIEWED: 5 (5M) [PATCHv3 4/9] mmc: dw_mmc: use the hold register when send stop command
2016-11-17 · Tested-by -
STALE3537d
REVIEWED: 3 (3M) [PATCHv3 5/9] mmc: dw_mmc: call the dw_mci_prep_stop_abort() by default
2016-11-17 · Tested-by -
STALE3537d
REVIEWED: 5 (5M) [PATCHv3 3/9] mmc: dw_mmc: change the DW_MCI_FREQ_MIN from 400K to 100K
2016-11-17 · Tested-by -
STALE3537d
REVIEWED: 5 (5M) [PATCHv3 2/9] mmc: dw_mmc: fix the debug message for checking card's present
2016-11-17 · Tested-by -
STALE3537d
REVIEWED: 5 (5M) [PATCHv3 1/9] mmc: dw_mmc: display the real register value on debugfs
2016-11-17 · Tested-by -
DORMANTno replies
REVIEWED: 3 (3M) [PATCHv2 07/10] mmc: dw_mmc: use the cookie's enum values for post/pre_req()
2016-11-15 · Tested-by -
STALE3540d
REVIEWED: 3 (3M) [PATCHv2 05/10] mmc: dw_mmc: call the dw_mci_prep_stop_abort() by default
2016-11-15 · Tested-by -
STALE3540d
REVIEWED: 3 (3M) [PATCHv2 04/10] mmc: dw_mmc: use the hold register when send stop command
2016-11-15 · Tested-by -
STALE3540d
REVIEWED: 3 (3M) [PATCHv2 03/10] mmc: dw_mmc: change the DW_MCI_FREQ_MIN from 400K to 100K
2016-11-15 · Tested-by -
STALE3540d
REVIEWED: 3 (3M) [PATCHv2 02/10] mmc: dw_mmc: fix the debug message for checking card's present
2016-11-15 · Tested-by -
STALE3544d
REVIEWED: 3 (3M) Re: [PATCH 00/13] mmc: dw_mmc: cleans the codes for dwmmc controller
2016-11-09 · Tested-by -
DORMANTno replies
REVIEWED: 10 (10M) [PATCH v4 1/2] Documentation: mmc: sdhci-of-arasan: add description of power domain
2016-09-27 · Reviewed-by -
STALE3685d
REVIEWED: 12 (12M) [PATCH v3 07/15] Documentation: mmc: sdhci-of-arasan: Add soc-ctl-syscon for corecfg regs
2016-06-20 · Reviewed-by -
STALE3685d
REVIEWED: 4 (3M) [PATCH v3 04/15] phy: rockchip-emmc: reindent the register definitions
2016-06-20 · Reviewed-by -
STALE3685d
REVIEWED: 10 (10M) [PATCH v3 10/15] Documentation: mmc: sdhci-of-arasan: Add ability to export card clock
2016-06-20 · Reviewed-by -
STALE3685d
REVIEWED: 4 (3M) [PATCH v3 01/15] phy: rockchip-emmc: give DLL some extra time to be ready
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 4 (3M) [PATCH v3 02/15] phy: rockchip-emmc: configure frequency range and drive impedance
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 6 (5M) [PATCH v3 13/15] phy: rockchip-emmc: Minor code cleanup in rockchip_emmc_phy_power_on/off()
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 3 (3M) [PATCH v3 09/15] arm64: dts: rockchip: Add soc-ctl-syscon to sdhci for rk3399
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 3 (3M) Re: [PATCH v3 14/15] phy: rockchip-emmc: Set phyctrl_frqsel based on card clock
2016-06-20 · Reviewed-by -
STALE3685d
REVIEWED: 8 (8M) [PATCH v3 08/15] mmc: sdhci-of-arasan: Properly set corecfg_baseclkfreq on rk3399
2016-06-20 · Reviewed-by -
STALE3685d
REVIEWED: 8 (8M) [PATCH v3 08/15] mmc: sdhci-of-arasan: Properly set corecfg_baseclkfreq on rk3399
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 6 (6M) [PATCH v3 11/15] mmc: sdhci-of-arasan: Add ability to export card clock
2016-06-20 · Reviewed-by -
STALE3685d
REVIEWED: 6 (6M) [PATCH v3 11/15] mmc: sdhci-of-arasan: Add ability to export card clock
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 5 (5M) [PATCH v3 06/15] mmc: sdhci-of-arasan: Always power the PHY off/on when clock changes
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 11 (10M) [PATCH v3 12/15] Documentation: phy: Let the rockchip eMMC PHY get an exported card clock
2016-06-20 · Reviewed-by -
STALE3685d
REVIEWED: 3 (3M) [PATCH v3 15/15] arm64: dts: rockchip: Provide emmcclk to PHY for rk3399
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 6 (5M) [PATCH v3 05/15] phy: rockchip-emmc: Increase lock time allowance
2016-06-20 · Tested-by -
STALE3685d
REVIEWED: 4 (3M) [PATCH v3 03/15] phy: rockchip-emmc: configure default output tap delay
2016-06-20 · Tested-by -
STALE3687d
REVIEWED: 3 (3M) Re: [PATCH v2 08/11] Documentation: phy: Let the rockchip eMMC PHY get an exported card clock
2016-06-18 · Reviewed-by -
STALE3687d
REVIEWED: 3 (3M) Re: [PATCH v2 06/11] Documentation: mmc: sdhci-of-arasan: Add ability to export card clock
2016-06-18 · Reviewed-by -
STALE3687d
REVIEWED: 3 (3M) Re: [PATCH v2 04/11] mmc: sdhci-of-arasan: Properly set corecfg_baseclkfreq on rk3399
2016-06-18 · Reviewed-by -
STALE3687d
REVIEWED: 3 (3M) Re: [PATCH v2 03/11] Documentation: mmc: sdhci-of-arasan: Add soc-ctl-syscon for corecfg regs
2016-06-18 · Reviewed-by -
DORMANTno replies
REVIEWED: 6 (6M) Re: [PATCH v2.1 07/11] mmc: sdhci-of-arasan: Add ability to export card clock
2016-06-16 · Reviewed-by -
DORMANTno replies
REVIEWED: 6 (6M) Re: [PATCH v2.1 07/11] mmc: sdhci-of-arasan: Add ability to export card clock
2016-06-16 · Tested-by -
STALE3687d
REVIEWED: 3 (3M) Re: [PATCH v2 0/11] Changes to support 150 MHz eMMC on rk3399
2016-06-16 · Tested-by -
STALE3719d
REVIEWED: 3 (3M) Re: [PATCH v3] mmc: dw_mmc: rockchip: Set the drive phase properly
2016-05-12 · Tested-by -
STALE4236d
[PATCH 3/3] ARM: dts: rk3288: Add drive/sample clocks for dw_mmc devices
2014-12-18 · Suggested-by -
STALE4236d
[PATCH 2/3] mmc: dw_mmc: Generic MMC tuning with the clock phase framework
2014-12-18 · Suggested-by -
STALE4236d
[PATCH 1/3] mmc: dw_mmc: dt-binding: Add tuning related things
2014-12-18 · Suggested-by