On Mon, 18 Oct 2021 11:04:49 -0700, Eric Biggers wrote:
This series renames struct blk_keyslot_manager to struct
blk_crypto_profile, as it is misnamed; it doesn't always manage
keyslots. It's much more logical to think of it as the
"blk-crypto profile" of a device, similar to blk_integrity_profile.
This series also improves the inline-encryption.rst documentation file,
and cleans up blk-crypto-fallback a bit.
[...]
Applied, thanks!
[1/4] blk-crypto-fallback: properly prefix function and struct names
commit: eebcafaebb17cb8fda671709fab5dd836bdc3a08
[2/4] blk-crypto: rename keyslot-manager files to blk-crypto-profile
commit: 1e8d44bddf57f6d878e083f281a34d5c88feb7db
[3/4] blk-crypto: rename blk_keyslot_manager to blk_crypto_profile
commit: cb77cb5abe1f4fae4a33b735606aae22f9eaa1c7
[4/4] blk-crypto: update inline encryption documentation
commit: 8e9f666a6e66d3f882c094646d35536d2759103a
Best regards,
--
Jens Axboe