On 1/22/21 3:48 AM, Andrew Jeffery wrote:
Randy found that with the following Kconfig settings we have duplicate
definitions (e.g. __inittest()) in sdhci-of-aspeed due to competing
module_init()/module_exit() calls from kunit and driver the itself.
CONFIG_MMC_SDHCI_OF_ASPEED=m
CONFIG_MMC_SDHCI_OF_ASPEED_TEST=y
Conditionally open-code the kunit initialisation to avoid the error.
Fixes: 7efa02a981d6 ("mmc: sdhci-of-aspeed: Add KUnit tests for phase calculations")
Reported-by: Randy Dunlap <redacted>
Signed-off-by: Andrew Jeffery <redacted>
---
v2:
* Collapse the #ifdef-ery
drivers/mmc/host/sdhci-of-aspeed-test.c | 9 +++++-
drivers/mmc/host/sdhci-of-aspeed.c | 42 ++++++++++++++++++++++---
2 files changed, 45 insertions(+), 6 deletions(-)
Acked-by: Randy Dunlap <redacted> # build-tested
Thanks.
--
~Randy