Re: [PATCH v2 17/34] kasan, x86, arm64, s390: rename functions for modules shadow
From: Catalin Marinas <catalin.marinas@arm.com>
Date: 2021-12-10 17:55:48
Also in:
linux-arm-kernel, lkml
From: Catalin Marinas <catalin.marinas@arm.com>
Date: 2021-12-10 17:55:48
Also in:
linux-arm-kernel, lkml
On Mon, Dec 06, 2021 at 10:43:54PM +0100, andrey.konovalov@linux.dev wrote:
From: Andrey Konovalov <redacted> Rename kasan_free_shadow to kasan_free_module_shadow and kasan_module_alloc to kasan_alloc_module_shadow. These functions are used to allocate/free shadow memory for kernel modules when KASAN_VMALLOC is not enabled. The new names better reflect their purpose. Also reword the comment next to their declaration to improve clarity. Signed-off-by: Andrey Konovalov <redacted>
For arm64: Acked-by: Catalin Marinas <catalin.marinas@arm.com>