Re: [PATCH v2 7/7] tools/testing/selftests/bpf: replace open-coded 16 with TASK_COMM_LEN
From: Sven Schnelle <svens@linux.ibm.com>
Date: 2021-11-29 14:24:15
Also in:
bpf, linux-fsdevel, linux-perf-users, lkml, netdev
Hi, Yafang Shao [off-list ref] writes:
quoted hunk
On Mon, Nov 29, 2021 at 6:13 PM Sven Schnelle [off-list ref] wrote:quoted
quoted
diff --git a/include/linux/sched.h b/include/linux/sched.h index 78c351e35fec..cecd4806edc6 100644 --- a/include/linux/sched.h +++ b/include/linux/sched.h@@ -274,8 +274,13 @@ struct task_group; #define get_current_state() READ_ONCE(current->__state) -/* Task command name length: */ -#define TASK_COMM_LEN 16 +/* + * Define the task command name length as enum, then it can be visible to + * BPF programs. + */ +enum { + TASK_COMM_LEN = 16, +};This breaks the trigger-field-variable-support.tc from the ftrace test suite at least on s390: echo 'hist:keys=next_comm:wakeup_lat=common_timestamp.usecs-$ts0:onmatch(sched.sched_waking).wakeup_latency($wakeup_lat,next_pid,sched.sched_waking.prio,next_comm) if next_comm=="ping"' linux/tools/testing/selftests/ftrace/test.d/trigger/inter-event/trigger-field-variable-support.tc: line 15: echo: write error: Invalid argument I added a debugging line into check_synth_field(): [ 44.091037] field->size 16, hist_field->size 16, field->is_signed 1, hist_field->is_signed 0 Note the difference in the signed field.Hi Sven, Thanks for the report and debugging! Seems we should explicitly define it as signed ? Could you pls. help verify it?diff --git a/include/linux/sched.h b/include/linux/sched.h index cecd4806edc6..44d36c6af3e1 100644 --- a/include/linux/sched.h +++ b/include/linux/sched.h@@ -278,7 +278,7 @@ struct task_group; * Define the task command name length as enum, then it can be visible to * BPF programs. */ -enum { +enum SignedEnum { TASK_COMM_LEN = 16, };
Umm no. What you're doing here is to define the name of the enum as 'SignedEnum'. This doesn't change the type. I think before C++0x you couldn't force an enum type. Regards Sven